Historical Dashboard's loading is affected
Incident Report for Chartbeat
Resolved
This incident has been resolved.
Posted Apr 29, 2024 - 17:21 EDT
Update
The Historical Dashboard is fully operational now.
Posted Apr 29, 2024 - 15:34 EDT
Investigating
Our engineering team is aware of issues affecting the loading of the Historical Dashboard and are actively investigating.
Posted Apr 29, 2024 - 14:24 EDT
This incident affected: Chartbeat Publishing - Historical Dashboards.