A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2025 - 18:14 EDT
Investigating
We are experiencing longer than usual load times in Chartbeat's Historical Dashboard and API due to a performance issue with Snowflake. Our team is investigating.
Posted Jul 21, 2025 - 08:58 EDT
This incident affected: Chartbeat Publishing - Historical Dashboards.