Historical Outage
Incident Report for Chartbeat
Resolved
Historical reporting is back up: please let support@chartbeat.com know if you're experiencing otherwise
Posted Sep 22, 2015 - 11:05 EDT
Investigating
Our developers are currently investigating a historical outage: check status.chartbeat.com for more information.
Posted Sep 22, 2015 - 10:04 EDT