HUD Issues
Incident Report for Chartbeat
Resolved
A fix has been pushed and users should again be able to load our Heads Up Display without issue
Posted 11 months ago. Nov 12, 2018 - 16:45 EST
Identified
We've identified the root cause of the reported HUD issues and are working to apply a fix as soon as possible
Posted 11 months ago. Nov 12, 2018 - 16:27 EST
Investigating
Our engineers are currently investigating user reports of our Heads Up Display not loading
Posted 11 months ago. Nov 12, 2018 - 15:49 EST
This incident affected: Chartbeat Publishing - Heads Up Display.