Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 10, 2026 - 17:00 EDT
Scheduled
We will be performing system maintenance on Monday August 10th between the hours of 5pm - 7pm EST. No disruption to service is expected. If you experience any issues during or after this window, please contact support@chartbeat.com.
Posted Aug 10, 2026 - 07:36 EDT
This scheduled maintenance affected: Chartbeat Publishing - Settings.