Delayed delivery of Reports emails
Incident Report for Chartbeat
Resolved
This incident has been resolved.
Posted Jan 04, 2023 - 23:30 EST
Investigating
Outages with a third-party vendor may cause a delay in some Reports emails. In the meantime, if you are missing one or more Reports in your email, you should be able to view them at https://chartbeat.com/reports/dashboard/

Our team will continue to monitor the outage and update the status page as we can.
Posted Jan 04, 2023 - 18:23 EST
This incident affected: Chartbeat Publishing - Reports.