No additional service interruption is expected during this maintenance window. We will update when maintenance has been completed.
Posted May 08, 2021 - 21:25 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 08, 2021 - 21:00 EDT
Scheduled
Chartbeat systems will be undergoing a brief scheduled maintenance at 9pm EST on Saturday, May 8. During this maintenance period, customers may briefly experience delays in loading Chartbeat dashboards and the Heads up Display. Please follow status.chartbeat.com for more information.