Publishing Dashboard Downtime
Incident Report for Chartbeat
Resolved
Publishing Dashboards are now restored and fully operational.
Posted Dec 15, 2015 - 14:15 EST
Investigating
All Dashboards are experiencing downtime. Our engineers are on the case and looking to resolve as soon as possible.
Posted Dec 15, 2015 - 13:36 EST