Engaged Headline Testing Downtime
Incident Report for Chartbeat
Resolved
Our developers have pushed a fix to resolve this issue. EHT is now back up and running.
Posted 10 months ago. Nov 21, 2016 - 11:11 EST
Investigating
We are currently experiencing downtime with Engaged Headline Testing, our devs are on the case
Posted 10 months ago. Nov 21, 2016 - 08:08 EST