Historical Dashboard Outage
Incident Report for Chartbeat
Resolved
This incident has been resolved.
Posted 3 months ago. May 10, 2017 - 09:55 EDT
Monitoring
Our developers have identified an outage involving the Historical Dashboard and are working to bring the tool back to full functionality.
Posted 3 months ago. May 10, 2017 - 01:21 EDT