Traffic Dips Impacting Snapshot Data
Incident Report for Chartbeat
Resolved
Our developers have resolved the issue causing traffic dips this morning.
Posted Mar 16, 2016 - 13:30 EDT
Investigating
Chartbeat's developers are looking into reports of traffic dips - stay up to date with the latest on status.chartbeat.com
Posted Mar 16, 2016 - 11:16 EDT