Heads Up Display - Degraded Performance
Incident Report for Chartbeat
Resolved
The Heads Up Display is back to full functionality.
Posted 9 months ago. Dec 20, 2016 - 12:59 EST
Investigating
We are experiencing degraded performance for the Heads Up Display. Our engineers are pushing a fix to restore full functionality
Posted 9 months ago. Dec 20, 2016 - 12:30 EST