Delayed Reports
Incident Report for Chartbeat
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 05, 2018 - 10:59 EST
Identified
Reports may be delayed by a few hours. Our developers are addressing the issue.
Posted 5 months ago. Jan 31, 2018 - 09:24 EST