Heads Up Display Latency
Incident Report for Chartbeat
Resolved
This incident has been resolved.
Posted Jun 10, 2016 - 13:40 EDT
Update
Resolved: HUD staus is back to normal
Posted Jun 10, 2016 - 11:18 EDT
Investigating
We're currently troubleshooting historical graph & CPM latency in the Heads Up Display
Posted Jun 10, 2016 - 10:34 EDT