Engaged Headline Testing Degraded Performance
Incident Report for Chartbeat
Resolved
Engaged Headline Testing is back up and running.
Posted over 1 year ago. Jan 18, 2017 - 12:30 EST
Identified
We're experiencing degraded performance for Engaged Headline Testing, our devs are on the case
Posted over 1 year ago. Jan 18, 2017 - 12:20 EST