Heads Up Display
Incident Report for Chartbeat
Resolved
This incident has been resolved.
Posted about 1 year ago. Dec 20, 2016 - 12:45 EST
Investigating
We are currently investigating an outage in the Heads up Display. We hope to have it back up shortly. Appreciate the patience.
Posted about 1 year ago. Dec 20, 2016 - 12:29 EST