Heads Up Display - Degraded Performance
Incident Report for Chartbeat
Resolved
The Heads Up Display is back to full functionality
Posted about 1 year ago. Oct 19, 2016 - 12:38 EDT
Identified
We are experiencing degraded performance for the Heads Up Display. Our engineers are pushing a fix to restore full functionality.
Posted about 1 year ago. Oct 19, 2016 - 08:48 EDT