Delayed Reports
Incident Report for Chartbeat
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 16, 2018 - 17:19 EST
Monitoring
Email Reports are currently delayed while our engineers perform maintenance on the underlying infrastructure.
Posted 3 months ago. Jan 10, 2018 - 18:23 EST