HUD Outage
Incident Report for Chartbeat
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 31, 2018 - 16:28 EST
Identified
Our developers are currently working to resolve an issue that is preventing the Heads Up Display from loading.
Posted 3 months ago. Jan 31, 2018 - 16:26 EST