We are currently experiencing a hiccup with the APIs the power the Heads Up Display. Our Developers are working as quickly as possible to resolve the issue. Stayed tuned for updates.
Incident Report for Chartbeat
Resolved
Our Dev team has resolved the Heads Up Display issue and the tool is now fully operational.
Posted Aug 03, 2015 - 18:07 EDT
Investigating
We are currently investigating this issue.
Posted Aug 03, 2015 - 17:14 EDT