Zendesk Downtime
Incident Report for Chartbeat
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 15, 2017 - 19:37 EDT
Investigating
Because of downtime in our customer email platform, the Chartbeat support team will be taking longer than usual to respond to tickets. For urgent support requests, you can reach out to your Account Manager or DM the @chartcorps Twitter handle
Posted 9 months ago. Mar 15, 2017 - 16:52 EDT