Possible Issues with the Heads Up Display
Incident Report for Chartbeat
Resolved
Heads Up Display is back to normal
Posted May 24, 2016 - 12:51 EDT
Investigating
We are currently investigating possible issues with our Heads Up Display
Posted May 24, 2016 - 12:30 EDT