Heads Up Display Outage
Incident Report for Chartbeat
Resolved
A fix has been pushed and full functionality has been restored to the HUD.
Posted 4 months ago. Apr 26, 2019 - 09:30 EDT
Investigating
We've identified a networking issue causing loading issues for the Heads Up Display. A fix is already in progress and we expect full HUD functionality to return shortly.
Posted 4 months ago. Apr 26, 2019 - 09:28 EDT
This incident affected: Chartbeat Publishing - Heads Up Display.