Heads Up Display Partial Outage
Incident Report for Chartbeat
Resolved
This incident has been resolved.
Posted May 27, 2015 - 10:53 EDT
Investigating
Some users may be experiencing an issue with loading the Heads Up Display on their browsers. Our Dev Team is actively working on identifying and resolving the issue. Please reach out to the Chartcorps at chart.bt/help if you have specific questions.
Posted May 27, 2015 - 10:42 EDT