We are currently monitoring Publishing dashboards after some reports of display issues.
Incident Report for Chartbeat
Resolved
The display issues have been resolved, all Dashboards should now be fully operational.
Posted Oct 08, 2015 - 12:00 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2015 - 11:34 EDT