Heads Up Display Outage
Incident Report for Chartbeat
Resolved
This incident has been resolved.
Posted Sep 02, 2015 - 13:43 EDT
Investigating
Some users may be experiencing intermittent issues with the Heads Up Display. We are currently investigating the situation and hope to have it back up and running for everyone as soon as possible. Please stay tuned for updates.
Posted Sep 02, 2015 - 13:32 EDT