Heads Up Display Outage
Incident Report for Chartbeat
Resolved
Our engineers have pushed a fix to the Heads Up Display, it's back up and running
Posted about 1 year ago. Jun 24, 2016 - 15:25 EDT
Investigating
Our engineers are on the case investigating an outage in our Heads Up Display. Stay tuned for updates
Posted about 1 year ago. Jun 24, 2016 - 15:13 EDT