Heads Up Display Outage
Incident Report for Chartbeat
Resolved
Our Heads Up Display is back up and running
Posted about 2 years ago. Jun 16, 2016 - 11:01 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 2 years ago. Jun 16, 2016 - 10:19 EDT
Investigating
We are currently investigating downtime with our Heads Up Display, updates to come
Posted about 2 years ago. Jun 16, 2016 - 09:29 EDT